Monday, 20 Nov 2017 | tralala:)
 

MDT 2013 Domain Join not working

Deploying machine via MDT 2013 was just fine when domain join suddenly stopped working.

 

  • Check the MDT log at (knowing when the join should occur) %systemroot%/Temp/DeploymentLogs/ZTIDomainJoin.txt
[LOG[DomainErrorRecovery Action: AutoRetry.]LOG]!>
[LOG[Initiating domain join operation using JoinDomainOrWorkgroup.]LOG]!>
[LOG[Initial attempt: JoinDomain(AD.example.com,PWD,AD.example.com\service_account-MDT,,3), rc = 1385]LOG]!>
[LOG[JoinDomain Failure: The account *may* already exist in a different OU. Retrying without the specified OU.]LOG]!>
[LOG[Retry attempt: JoinDomain(AD.example.com,PWD,AD.example.com\service_account-MDT,,3), rc = 1385]LOG]!>
[LOG[Initiating a reboot.]LOG]!>
[LOG[Property LTISuspend is now = ]LOG]!>

[LOG[ZTIDomainJoin processing completed successfully.]LOG]!>

 

  • Check the %systemroot%/Debug/NetSetup.log
0/10/2014 10:40:11:648 NetpValidateName: checking to see if 'AD.example.com' is valid as type 3 name
10/10/2014 10:40:11:648 NetpValidateName: 'AD.example.com' is not a valid NetBIOS domain name: 0x7b
10/10/2014 10:40:11:758 NetpCheckDomainNameIsValid [ Exists ] for 'AD.example.com' returned 0x0
10/10/2014 10:40:11:758 NetpValidateName: name 'AD.example.com' is valid for type 3
10/10/2014 10:40:11:758 NetpDsGetDcName: trying to find DC in domain 'AD.example.com', flags: 0x40001010
10/10/2014 10:40:11:867 NetpLoadParameters: loading registry parameters...
10/10/2014 10:40:11:867 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2
10/10/2014 10:40:11:867 NetpLoadParameters: DomainCompatibilityMode not found, defaulting to '0' 0x2
10/10/2014 10:40:11:867 NetpLoadParameters: status: 0x2
10/10/2014 10:40:11:867 NetpDsGetDcName: status of verifying DNS A record name resolution for 'DC.AD.example.com': 0x0
10/10/2014 10:40:11:867 NetpDsGetDcName: found DC '\\DC.AD.example.com' in the specified domain
10/10/2014 10:40:11:867 NetpJoinDomainOnDs: NetpDsGetDcName returned: 0x0
10/10/2014 10:40:11:882 NetUseAdd to \\DC.AD.example.com\IPC$ returned 1385
10/10/2014 10:40:11:882 NetpJoinDomain: status of connecting to dc '\\DC.AD.example.com': 0x569
10/10/2014 10:40:11:882 NetpJoinDomainOnDs: Function exits with status of: 0x569
10/10/2014 10:40:11:882 NetpDoDomainJoin: status: 0x569
 
  • Realize that 1385 is the eror code. Execute „net helpmsg 1385
Logon failure: the user has not been granted the requested logon type at this computer.
 
  • Recall changes to AD Domain, Deny Log On Locally should not be enabled across the domain for MDT join Account
 
 
Did you know?

That this button does nothing?

Follow Us
Topics

Hyper-V

IT Pro

Random

Get in touch

Would you like to share something interesting with me? Mail: info at rozmazat.cz